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Preface

The outlines the procedures for installing and using DECevent NT and also discusses the 
program’s functionality and troubleshooting options.

Intended Audience

This document is intended to assist anyone who uses DECevent NT to translate, analyze, 
display event logs, or generate reports.

Documentation Conventions

The following conventions are used in this guide:

Related Documents

For more information about the use and operation of this software, refer to the DECevent NT 
4.1 User Guide.

User Entries Information that should be entered exactly as it appears in 
the document is shown in bold.

Variables Information that will vary depending on your computer or 
user profile is shown in italics.

System Output Responses from the system are shown in a monospaced 
font.
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Further Information

ad 
on.
Further Information

For more information about DECevent NT, refer to the Compaq web site at the following 
URL:

http://www.compaq.com/services 

Select the “Service Tools Link” and then the “Download the Tools” link. From the downlo
page you can access the DECevent NT page which contains the latest kits and documentati
Rev.1/28/00–A
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1
Introduction

This chapter introduces DECevent NT and briefly discusses its capabilities.

Overview. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 1–2

Functionality . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 1–2
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Introduction
1.1 Overview
1.1 Overview

DECevent NT is an event management utility that analyzes and translates Windows NT 
system events. Events are functional errors within a computer system or a piece of associated 
hardware. When DECevent NT detects an event, it translates it into readable text, analyzes it 
to determine the cause, and reports the event and possible solutions in the event logger.

To use DECevent NT, you must have access to the event log file that you wish to view. The 
nature of the event determines both the type of system response and how the event is stored 
within the system. There are two types of events that DECevent NT monitors:

Uncorrectable Errors

Uncorrectable errors occur when a fault within a computer or a piece of associated hardware 
causes the system to detect an inconsistency in its mode of operation. When this occurs, the 
system writes the event into a crash file known as the Application Event Log, and shuts itself 
down. The system searches the Application Log for the crash file when it is rebooted. If the 
file is found, the event is added to the event log, which receives, records, and compiles all of 
the events that occur within the system. The event log holds all of this information until the 
user requests to have it pulled.

Correctable Errors

Correctable errors do not cause the computer system to shut down, but the system does 
recognize and attend to the error. When correctable errors occur, the operating system device 
driver collects the information and writes it directly into the Application Event Log. The error 
information is held there with other correctable and uncorrectable errors until the user pulls the 
information for analysis or translation. In addition, DECevent NT detects NT-specific errors 
that involve security, applications, and the overall system.

1.2 Functionality

DECevent NT utilizes separate features to translate and analyze error logs and perform 
notification.

1.2.1 Translation

With DECevent NT, you can translate system, application, or security events. During 
translation, the binary portion of an event log is translated into plain text. For central 
processors supported by DECevent NT, additional information is added to the translated 
events to help you determine what error has occurred. DECevent NT analyzes the event so that 
a repair action can be recommended. With translation, you can also:

• View multiple event logs

• Connect to event logs across a network
Rev.1/28/00–A
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1.3 Supported Devices
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• Mail event logs

• Save event logs

• Print reports

1.2.2 Analysis

Note

The PC-based DECevent NT kit only supports the view capability and does not 
support analysis.

Analysis uses inference to determine the cause of an error. When pertinent information is 
available for known errors, DECevent NT infers a service repair action and processes an
analysis. The output recommends which Field Replaceable Unit (FRU) to replace. Thes
events display on the screen and can be printed or sent via electronic mail. 

1.2.3 Automatic Analysis and Notification

Automatic Analysis translates data from an event log into usable segments of informatio
entries received in the event log are immediately sent for analysis. The event log is then
monitored for a specified time period and tracks the number of identical events that occu
When a predetermined number of event logs is exceeded, the events are displayed as a
potential problem. 

Automatic Notification allows you to establish notification venues that report error logs a
suggested repair information, registry information, and previous repair history. You can s
one of the following notification methods:

• Electronic mail notification to engineers and users

• A system-initiated call logging system (SICL) that transfers the information to the 
Customer Service Center (CSC)

• A web-based self-help system that provides suggestions on how to fix a particular f
that is detected in the system

1.3 Supported Devices

For information on the devices supported by the current version of DECevent NT, refer to the 
DECevent NT Release Notes.
Rev.1/28/00–A

DECevent NT    User Guide    1–3



Introduction
1.4 Installing DECevent NT
1.4 Installing DECevent NT

Installation instructions for DECevent NT and Automatic Analysis are contained in the 
DECevent NT Release Notes.
Rev.1/28/00–A
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Graphical User Interface

This chapter explains how to use the Graphical User Interface (GUI).

Overview. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 2–2
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2.1 Overview
2.1 Overview

The Graphical User Interface (GUI) can be used to view event logs, translate and analyze 
events, and configure automatic analysis and notification. 

Select Programs | Administrative Tools (Common) | DECevent NT from the Start menu to 
launch DECevent NT. 

When you first start the GUI, the Event Log window is displayed. The Event Log window 
shows the individual events in the current host’s event log.

Figure 2–1  DECevent NT Main Window

2.2 Navigating the GUI

The following sections describe the menu options and other navigation features of the 
DECevent NT GUI.

2.2.1 Menus

The following sections describe the menus available through the GUI.
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2.2 Navigating the GUI
2.2.1.1 File Menu

The File Menu options are described in Table 2–1.

2.2.1.2 Edit Menu

The Edit Menu contains standard windows options. For more information, refer to your 
operating system documentation.

2.2.1.3 View Menu

The View Menu options are described in Table2–2.

Table 2–1  File Menu

Option Description

System Opens the System log.

Security Opens the Security log.

Application Opens the Application log.

New Opens a new log window.

Open Opens a DECevent file.

Close Closes the active log window.

Close All Closes all the open log windows.

Save Saves the log file.

Save As Saves the log file using a different name.

Connect Connects to another computer and enables remote analysis.

Print Prints the active log file.

Print Preview Shows a preview of the printed output for the active log file.

Print Setup Enables you to select a printer and print options.

Send Attaches the active log file to a e-mail message that you can send.

Recent File Provides quick access for recent files.

Exit Closes DECevent NT and all the open windows.
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2.2.1.4 Window Menu

The window menu contains standard windows functions. Refer to your operating system 
documentation for more details.

2.2.1.5 Options Menu

The Options Menu options are described in Table 2–3.

2.2.1.6 Help Menu

The Help Menu options are described in Table2–4.

Table 2–2  View Menu

Option Description

Toolbar Toggles the display of the toolbar.

Status Bar Toggles the display of the status bar located at the bottom of the 
window.

Analysis Opens a window and shows the results of analyzing the selected 
event or events.

Translate Opens a window and shows the results of translating the selected 
event or events.

Hex Dump Opens a window and displays the results of dumping the hex code 
from the event or events.

Table 2–3  Options Menu

Option Description

Analysis Opens the Analysis Configuration dialog, enabling you to change 
the analysis settings.

Auto Analysis & 
Notification

Opens the Auto Analysis and Notification Configuration dialog, 
enabling you to change the settings.

Translation Opens the Translation Configuration dialog, enabling you to change 
the settings.
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2.2.2 Pop-up Menu

Right clicking on an event from the Event Log window displays a pop-up menu. 

• Analysis 

• Translation 

• Hex Dump 

The functions on the pop-up menu are also available from the View Menu.

2.2.3 Toolbar

The Toolbar contains shortcut icons for common menu functions. The available options 
the menu where the command is located are given here:

• New — File Menu 

• Open — File Menu 

• Save — File Menu 

• Cut — Edit Menu 

• Copy — Edit Menu 

• Paste — Edit Menu 

• Print — File Menu 

• Help Contents — Help Menu 

You can show or hide the toolbar by selecting or deselecting the Toolbar option on the v
menu.

2.3 Working with Event Logs

Initially, the main window displays the event log that is set as your default in the Windows
Event Viewer. If you wish to view one of the other logs, you can either add the events from
log to the existing display or open a new window for the events.

Table 2–4  Help Menu

Option Description

Help Contents Displays the on-line help.

About DECevent Displays version and copyright information.
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2.3 Working with Event Logs
2.3.1 Organizing Events

Normally, events are organized according to their record number with the most recent records 
shown first. You can organize the events based on any of the displayed fields by clicking on 
the field name. The first time you click on a field name the events are sorted in descending 
order. To list the events in ascending order, click the field name again.

2.3.2 Combining Event Logs

To add the events from another log file to the current display, simply select the desired file 
from the File pull-down menu. The events from the log file are added to the Event Log 
window and the title bar on the window is changed to reflect all the open logs. For example, if 
you have the application and security logs open, the title bar reads 
application.security.

If you want, you can open all three logs and combine the events in a single window.

2.3.3 New Event Log Windows

If you want to keep the events from the various logs separate, you can open a new Event Log 
window for each log file.

1. Open a blank event log window by selecting Open from the File menu.

2. With the new window active, select the desired log from the File pull-down menu.

The event log window is populated with the events from the log file and the title bar is 
changed to reflect the open log file.

2.3.4 Copying Events

If you want to work with a subset of the events from an event log, you can copy those events to 
a new window using the following procedure:

1. Open a blank event log window by selecting Open from the File menu.

2. Select the desired events from the log file. To select multiple events, hold the control key 
while you select the events.

3. Drag the events to the new window, when a + appears on the cursor the release the mouse.

The selected events are added to the new window. You can combine the events from 
several different event log windows in a single window using this method.

By copying the relevant events to a new window, you can translate and analyze them without 
having to select each event for every operation.
Rev.1/28/00–A
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2.3.5 Saving Events

You can save the contents of an event log window using the Save and Save As options from 
the file menu. Events logs are saved in binary format with an extension of .dnt to indicate that 
the file originated in DECevent NT. Be aware that files in this format cannot be read by the 
Microsoft Event Viewer.

2.4 Translating Events

To look at specific information about an event or events, you can translate the event(s). 
Translation output is shown in a dialogue box that includes a brief description of the event and 
information about when the event occurred and the event type.

2.4.1 Setting Translation Output Options

Select the Translation option from the Options menu to change the output settings. Figure 
shows the dialog box.

Figure 2–2  Output Options Dialog

The options are used to set the appearance of the output file. If you make changes, you can 
either click the OK button to apply them or click the Cancel button to revert to your previous 
settings.
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Be aware that these settings will also influence the output of hex dumps and analysis results.

2.4.2 Translating Events

To translate events, use the following procedure:

1. Select the event or events you want to translate from the Event Log window.

To select multiple events simultaneously, hold down the CTRL key while you select the 
events.

2. Translate the events using one of the following methods:

• Right-click on the selected event and choose Translate from the pop-up menu. If
you have multiple events selected, continue to hold the CTRL key while you
right-click.

• Double-click on the selected event. If you have multiple events selected, continu
to hold the control key while you double-click.

• Select Translate from the View pull-down menu.

A translation window similar to the one in Figure2–3 appears. If you translated multiple
events, the output for every selected event is shown.

Figure 2–3  Translation Window

The translation output shows the text translation the event information.

2.5 Analyzing Events

Performing analysis determines what caused an event and provides recommendations to 
correct the problem. 
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2.5.1 Setting Analysis Options

To configure the Analysis settings, select Analysis from the Options menu. The Analysis 
Options dialogue box contains two tabs, one for Knowledge Rule Sets, and one for Analysis 
Debugging.

Knowledge Rule Sets

The Knowledge Rule Sets tab is shown in Figure 2–4.

Figure 2–4  Knowledge Rule Sets Tab

The Knowledge Rule Sets tab allows you to add or remove Rule Sets from the analysis 
process. Be aware that some Rule Sets are automatically enrolled when DECevent NT is 
installed.

To add a Rule Set, use the following procedure:

1. Click the Enroll Rule Set button. 

A window displays the Knowledge Rule Set (.KRS) files in the DECevent directory. 

2. If the Rule Set file that you want to add is not in the default directory, navigate to the 
folder that contains the appropriate file. 

3. To add the Rule Set, either click once on the filename and choose “Open,” or double-click 
on the filename.

To withdraw a Rule Set, use the following procedure:

1. Select a Rule Set file name. To select more than one Rule Set, hold the CTRL key 
you select the files.

2. Click the Withdraw Rule Set button. 
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To withdraw all of the Rule Sets at once, click the Withdraw All button. It is not necessary to 
select the Rule Set files before clicking Withdraw All.

Analysis Debugging

The Analysis Debugging tab is shown in Figure 2–5.

Figure 2–5  Analysis Debugging Tab

Service engineers can access this tab to select flags that will produce debugging output and 
trace information during an analysis. The debug information displays in a separate analysis 
window.

2.5.2 Analyzing Events from the Event Window

You can either analyze all the events in the Event Log or analyze a select group of events.

Analyzing All Events

To analyze all of the events in the Event Log window, either select Analysis from the View 
pull-down menu or right-click anywhere on the event window and select Analysis from the 
pop-up menu.

A prompt, indicating the amount of time taken to analyze the events, appears when analysis is 
finished. The analysis results are shown in an Analysis Window similar to the one in Figure.

Analyzing Select Events

To analyze selected events, use the following procedure:

1. From the Event Log window, select the event or events that you wish to analyze. Use the 
CTRL key to choose multiple events.

2. Initiate analysis using one of the following methods:
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• Right-click on the selected events, and choose Analyze from the pop-up menu. If 
you selected multiple events, continue to hold the CTRL key while you right 
click.

• Select Analysis from the View pull-down menu.

A prompt indicating how long it took your CPU to analyze the event(s) appears, and
analysis results are shown in an Analysis Window (Figure2–6). 

Figure 2–6  Analysis Results

The left column provides a count of the findings and the right column lists the findings. You 
can click the + next to the findings in the left column to see an extended list of the events that 
appear in the right column.

2.5.3 Viewing Analysis Results

To see a detailed description of the analysis, double-click on the event in the right-hand 
column under the Derivation heading. A text window that details specific data about the event 
appears. See Section 2.7 for more information on working with the results text file.

Note

It is important to look in the text window to verify that the analysis results are 
plausible and accurate.
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2.6 Hex Dump

A Hex Dump allows you to look at the hex information of a particular event or events. When 
you initiate a Hex Dump, DECevent NT converts bit information into hex, removes the 
translation information, and dumps the log with packet offsets.

Note

You can conduct a Hex Dump on System, Security, and Application log files.

2.6.1 Viewing a HexDump from the Event Window

To see a HexDump of an event or events, follow these procedures:

1. Determine the event or events that you want to see a Hex Dump for and select them from 
the main event window. If you want to select multiple events, hold the CTRL key while 
making your selections.

2. Initiate the hex dump using one of the following methods:

• Right-click on the selected event and choose Hex Dump from the pop-up me
If you have multiple events selected, continue to hold the CTRL key while yo
right-click.

• Select Hex Dump from the View menu.

A text window containing the Hex Dump output appears 

2.6.2 Hex Dump Output

Hex Dump output resembles the following example:

Event:1150 EventId:-2147155941 Node:GALILEO Source:Ftdisk
Dump of Event Body
** NT Header **
EvtOffset PacOffset Len value
00000008 00000008 004 Record Number ...x0000047e
0000003f 0000003f 008 Computer Name ...GALILEO
00000038 00000038 007 Source Name .....Ftdisk
00000049 00000049 000 User SID ........
00000014 00000014 004 Event ID ........x8005001b
00000018 00000018 002 Event Type ......x0002
0000001c 0000001c 002 Event Category ..x0000
0000000c 0000000c 004 Time Generated ..x37cbea86
00000010 00000010 004 Time Written ....x37cbeaa4
00000049 00000049 018 Strings .........\Device\FtControl
0000005b 0000005b 040 Event Data
......0000000001005600000000001b0005800000000000000000000000000000000000000
00000000000
Event:1133 EventId:-1073479671 Node:GALILEO Source:Symc8XX
Dump of Event Body
Rev.1/28/00–A
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** NT Header **
EvtOffset PacOffset Len value
00000008 00000008 004 Record Number ...x0000046d
00000040 00000040 008 Computer Name ...GALILEO
00000038 00000038 008 Source Name .....Symc8XX
00000050 00000050 000 User SID ........
00000014 00000014 004 Event ID ........xc0040009
00000018 00000018 002 Event Type ......x0001
0000001c 0000001c 002 Event Category ..x0000
0000000c 0000000c 004 Time Generated ..x37cab675
00000010 00000010 004 Time Written ....x37cb2152
00000050 00000050 018 Strings .........\Device\ScsiPort0
** IO error **
EvtOffset PacOffset Len value
00000062 00000000 001 Major Function Code x00
00000063 00000001 001 Retry Count .....x00
00000064 00000002 002 Dump Data Size ..x0010
00000066 00000004 002 NumberOfStrings .x0001
00000068 00000006 002 String Offset ...x0068
0000006a 00000008 002 Event Catagory ..x0000
0000006e 0000000c 004 Error Code ......xc0040009
00000072 00000010 004 Unique Error Value x50000101
00000076 00000014 004 Final status ....x00000000
0000007a 00000018 004 Sequence Number .x00000000
0000007e 0000001c 008 IO control code .x0000000000000000
00000086 00000024 004 Device offset ...x00000000
** Scsi and mini port driver **
EvtOffset PacOffset Len value
0000008a 00000000 004 PathId ..........x00000000
0000008e 00000004 004 TargetId ........x00000000
00000092 00000008 004 Logical Unit Number x00000000
00000096 0000000c 004 Error code ......x00000007
.
.
.

Since Hex Dump output is shown in the text window, it can be manipulated as described in 
Section 2.7.

2.7 Working with Results

The results of translation, analysis and hex dumps are shown in text windows and formatted 
according to your preferences. You can use the mouse to select text from the window and the 
Text pull-down menu to manipulate the output. Table 2–5 describes the menu options:

Table 2–5  Text Menu

Option Description

Find Searches the text file for a specific string.

Select All Selects all the text in the output file.

Copy Copies the selected text to the clipboard.

Save As Saves the output as a text file.
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2.8 Automatic Analysis and Notification Manager

By default the GUI works in manual mode, where you specify the events to translate and 
analyze. By setting up automatic analysis you can eliminate the need to manually specify 
events for processing. Notification enables you to send the results of analysis to other users 
and groups.

2.8.1 Configuring Automatic Analysis and Notification

You can access Automatic Analysis and Notification Manager configuration options from 
either the GUI interface or the Control Panel.

• From the GUI, select Auto Analysis & Notification from the Options menu to access
configuration.

• From the Windows NT Control Panel, double-click the Analysis and Notification icon
access the configuration.

The configuration window has two tabs, Auto Analysis and Notification.

Auto Analysis Tab

The Auto Analysis Tab specifies the system logs to track and the time period for scannin
events. You can also perform a test analysis and review the operating status of the Auto
Analysis background service. The Auto Analysis tab is shown in Figure2–7.
Rev.1/28/00–A
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Figure 2–7  Auto Analysis Tab

Table 2–6 details the functionality of the Auto Analysis tab.

Table 2–6  Auto Analysis Tab

Option Description

Current Status Displays information about the current operating state of Automatic 
Analysis. If Automatic Analysis is running and responding, it sends 
back a status report that gives more information about its current 
processing state.

Logs to Monitor This enables you to select which logs you want the Automatic 
Analysis process to monitor. Windows NT maintains system, 
application and security event logs. Logs with a check next to them 
are monitored for new events and logs without a check are ignored.
DECevent NT immediately analyzes events in the monitored logs. 
Notification occurs if a recognizable error condition is found. If the 
Automatic Analysis is already running, changes will not take place 
until you press the Apply, OK, or Close button.
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Notification Tab

From the Notification Tab, you can establish the notification method for error reporting, verify 
notification status and access customer information. 

Figure 2–8  Notification Tab

Table 2–7 describes the Notification tab:

Log Scan Period When you start Automatic Analysis, DECevent NT checks the event 
log for events that occurred before the process was started. The Log 
Scan Period indicates the oldest event that DECevent NT will 
process. The time is specified in days, hours, minutes, and seconds. 
No events older than the scan cutoff time are processed for any log 
file.

Test This button checks for any change in the processing state, any new 
events, and any new notifications.

Service Control Buttons These buttons enable you to install, uninstall, start, and stop the 
Automatic Analysis background service. 
The Automatic Analysis service must first be installed before it can 
be started.

Table 2–6  Auto Analysis Tab (continued)

Option Description
Rev.1/28/00–A
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2.8.2 Starting Automatic Analysis

Once you have installed Automatic Analysis, you can launch the application any time by 
selecting Auto Analysis & Notification from the Options menu and clicking the Start button 
on the Auto Analysis tab.

2.8.3 Automatic Analysis Test Function Support

You can test the automatic analysis capability of DECevent NT and send the test results to the 
Customer Support Center (CSC). You can perform a test by clicking the Test button from the 
Automatic Analysis and Notification window (see Table 2–6). 

If your system is set up to notify CSC, the test results will be sent there.

2.8.4 DSNlink

DSNlink is a service tool that provides electronic product support to authorized users. If 
activate DSNlink, its cryptographic authentication procedures ensure secure communica

Table 2–7  Notification Tab

Option Description

Notification Methods There are two methods used to notify service representatives of 
problems detected by Automatic Analysis.
• SMTP mail, or Internet e-mail.
• System Initiated Call Logging (SICL), which requires COMPAQ's 

DSNlink package to function properly. 
Either or both notification methods can be used.

Notification Method Status The Automatic Analysis & Notification Manager tries to determine if 
SMTP mail and DSNlink are operating properly and reports the 
status of each.

SICL Acknowledge Email 
Address

When a call center receives a SICL notification, it sends an e-mail 
with verification and status information to the e-mail address 
specified in this field. This field is required for proper SICL operation. 

Customer Profile 
Information

Enter the information required by service representatives to help 
solve system problems in this field. This information includes your 
access number, company name, address, system type and serial 
number, contact name, phone number, special instructions, and any 
other relevant information. Entries in this field are included in 
notification messages, and neglecting to enter this information can 
delay service.

Configure SMTP This button brings up the SMTP Notification Setup dialogue box, 
which enables you to configure and test SMTP email.
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between the DSNlink system at your site and the DSNlink host systems at Compaq Customer 
Support Centers. Most DSNlink versions allows you to:

• Submit and track service requests

• Copy files to and from Compaq

• Access technical support databases

• Request or download engineering change orders (ECOs)

• Send e-mail pertaining to supported products

• Set up a centralized DSNlink system via your network. 

For more information about DSNlink, refer to the DSNlink web page or online help.

Downloading DSNlink

To receive the latest version of DSNlink, you can contact your local Customer Support C
or download the kit from the Compaq Support web site, at the following URL:

http:/ /www.compaq.com/support 

From the main support page, select the “Service Tools” link under the “Downloadable Dr
& Utilities” heading. Select the “Download the Tools” link and then select the “DSNlink” li

The web site describes DSNlink’s requirements and capabilities. Choose the kit that coin
with your operating system, and the links will guide you through the download process.

2.9 Closing the GUI

Closing the GUI normally involves stopping Automatic Analysis and then closing the GU
window. 

Stopping Automatic Analysis

To stop automatic analysis, use the following procedure:

1. Select Auto Analysis & Notification from the Options menu.

2. Click the Stop button.

3. Click the OK button to apply your changes.

Closing the GUI

Close the GUI by selecting Exit from the File menu or using the windows close button.
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3
Using the Command Line

This chapter describes how to run and operate the DECevent NT command line interface. 

Using the Command Line Interface  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 3–2

Command Format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . pa

Examples. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . page 3–3
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3.1 Using the Command Line Interface

To use the DECevent NT Command Line Interface (CLI), open a command prompt and access 
the directory where DECevent NT is installed. By default, DECevent NT is installed in the 
following directory:

C:\ PROGRAM FILES\DIGITALSERVICES\DECEVENT

3.2 Command Format

CLI commands have the following format:

DECeventCLI SwitchName SystemLogFilename 

Where SwitchName is one of the processing switches described in Table 3–1 and 
SystemLogFilename is the name of the log you want to process (see Section3.2.2).

3.2.1 Switches

Table3–1 describes the switches available to the CLI.

Table 3–1  CLI Switches

Switch Description

Core Switches

/l List — Lists all events (this is the default operation).

/t Translate — Translates events.

/a Analyze — Analyzes events.

Supplementary Switches

/c  List with Comma — Lists all events and separates them with a 
comma so the data can be entered into a spread sheet.

/d Dump Hex — Displays the bit-to-hex dump with packet offsets and 
no translation.

/s=time Start Time — Selects the starting time range (inclusive) for events.

/e=time End Time — Selects the ending time range (inclusive) for events.

/p=[source1,sourceN] Producer — Selects event entries by case-sensitive source name.

/o=[source1,sourceN] Overlook — Deselects event entries by case-sensitive source name.

/b=< filespec>1  Batch — Accepts a file that contains DECevent NT commands that 
are to be executed.
Rev.1/28/00–A
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Using Multiple Switches

Multiple switches can be combined in one command sequence to perform more than one 
action at a time.

Be sure to use the proper syntax when you use the /p, /o, or /r switch with the /l switch. The 
event series must be surrounded by quotation marks.

3.2.2 Log Files

The following log files are available for processing and can be substituted for the 
SystemLogFilename:

• APPLOG - application log

• SYSLOG - system log

• SECLOG - security log

3.3 Examples

The following section shows examples of the various CLI commands and the resulting o

Note

The examples in this section are not exhaustive; other log files can be processed and 
other combinations of switches can be used. In addition, the output shown is often 
truncated.

/m  Mode — Changes the CLI to interactive mode, which allows CLI to 
continue running between commands.

/f=< filespec>  Results File — Specifies a results file.

/k  Kill — Exits interactive or batch mode.

Independent Switches

/i Processes events in reverse order.

/h or /? Help — Displays an online menu of the DECevent NT CLI switches.

/x Suppresses timestamp output.

1 This command operates in interactive mode, execute a /k command to exit this sequence.

Table 3–1  CLI Switches (continued)

Switch Description
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3.3.1 Listing Events

To see a list of the events that have occurred on your system, use the following command:

deceventcli /l syslog 

Output

02:31:18 15 Error
1106 1692 atapi ..................SYSTEM1......156 06-Oct-1998
02:31:42 15 Error
1107 1693 atapi ..................SYSTEM1......156 06-Oct-1998
02:32:06 15 Error
1108 1694 atapi ..................SYSTEM1......156 06-Oct-1998
02:32:30 15 Error
1109 1695 atapi ..................SYSTEM1......156 06-Oct-1998
02:32:54 15 Error
1110 1696 atapi ..................SYSTEM1......156 06-Oct-1998
02:33:18 15 Error
1111 1697 atapi ..................SYSTEM1......156 06-Oct-1998
02:33:42 15 Error
1112 1698 atapi ..................SYSTEM1......156 06-Oct-1998
02:34:06 15 Error
1113 1699 atapi ..................SYSTEM1......156 06-Oct-1998
02:34:30 15 Error
1114 1700 atapi ..................SYSTEM1......156 06-Oct-1998
02:34:54 15 Error
1115 1701 atapi ..................SYSTEM1......156 06-Oct-1998
.
.
.

3.3.2 Listing Specific Events

To view certain events or a range of events, use the range switch. The following command 
would show events 11, 33 and events 87 through 89:

deceventcli /l syslog /r="11, 33, 87-89" 

Output

DECeventCLI NT v4.0
Fri Sep 03 10:56:55 1999
------------------------------------------------------------------
Processing : "syslog"
Criteria Match : 5 of 2711 events
*******************
* Event Listing *
*******************
ENTRY RECORD SOURCE COMPUTER BYTES EVENT TIME
ID TYPE
-------------------------------------------------------------------
11 597 atapi ................SYSTEM1 ...... 156 05-Oct-1998
19:28:31 15 Error
33 619 atapi ................SYSTEM1...... 156 05-Oct-1998
19:37:20 15 Error
87 673 atapi ................SYSTEM1...... 156 05-Oct-1998
19:56:04 15 Error
88 674 Cdrom ................SYSTEM1...... 156 05-Oct-1998
19:56:04 11 Error
89 675 atapi ................SYSTEM1...... 156 05-Oct-1998
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19:56:24 15 Error

3.3.3 Listing Events Within a Specified Time Period

To see the events that occurred within a specific time period, use the start time and end time 
switches.

Note

The switches use the DD-MMM-YYYY format for the date. If you specify a time, use 
the hh:mm:ss format.

For example, to see the events that occurred between August 25, 1999 and 12:30 PM on 
August 30, 1999, enter the following:

decevent cli /l syslog /s=25-aug-1999 /e=30-aug-1999,12:30:00 

Output

2707 3293 EventLog ....................SYSTEM1...124 25-Aug-1999
12:33:05 6009 Info

2708 3294 EventLog ....................SYSTEM1...84  25-Aug-1999
12:33:05 6005 Info

2709 3295 Mouclass ....................SYSTEM1...152 26-Aug-1999
13:38:32 11 Info

2710 3296 Mouclass ....................SYSTEM1...152 30-Aug-1999
11:24:58 11 Info

2711 3297 Mouclass ....................SYSTEM1...152 30-Aug-1999
11:43:43 11 Info

3.3.4 Translating Events Using CLI

In order to see a translation of events, use the following CLI command:

deceventcli /t syslog 

Output

DECeventCLI NT v4.0
Thu Sep 02 17:31:00 1999
-------------------------------------------------------------------
Processing : "syslog"
Criteria Match : 2711 of 2711 events
*******************
* Translation *
*******************
Entry Number 1
Record Number 587
Computer Name SYSTEM1
Source atapi
User Name N/A
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Event Identifier 15
Event Type Error
Event Category 0
Time Generated 10/05/98 19:24:31
Time Written 10/05/98 19:24:31
Brief Description of Event:

The device, \Device\ScsiPort1, is not ready for access yet.
Dump of event data:

0000: 0F 15 14 00 01 00 64 00 ¤§.?.d.
0008: 00 00 00 00 0F 00 04 C0 ....¤.?+
0010: 03 01 00 00 A3 00 00 C0 ??..ú..+
0018: 01 54 00 00 00 00 00 00 ?T......
0020: 00 00 00 00 00 00 00 00 ........
0028: 00 00 00 00 00 00 00 00 ........
0030: 00 00 00 00 00 00 00 00 ........
0038: 07 00 00 00 ...

*******************************************************************
Entry Number 2
Record Number 588
Computer Name SYSTEM1
Source atapi
User Name N/A
Event Identifier 15
Event Type Error
Event Category 0
Time Generated 10/05/98 19:24:55
Time Written 10/05/98 19:24:55
Brief Description of Event:

The device, \Device\ScsiPort1, is not ready for access yet.
Dump of event data:

0000: 0F 15 14 00 01 00 64 00 ¤§.?.d.
0008: 00 00 00 00 0F 00 04 C0 ....¤.?+
0010: 03 01 00 00 A3 00 00 C0 ??..ú..+
0018: 16 54 00 00 00 00 00 00 ?T......

.

.

.

3.3.5 Translating Events From a Specified Day

If you want to look at a translation of events that occurred on a specific day, use the start 
switch.

For example, to see events that occurred on August 30, 1999, enter:

decevent cli /t syslog /stime=30-aug-1999 

Output

Entry Number 2710
Record Number 3296
Computer Name SYSTEM1
Source Mouclass
User Name N/A
Event Identifier 11
Event Type Informational
Event Category 0
Time Generated 08/30/99 11:24:58
Time Written 08/30/99 11:24:58
Brief Description of Event:

The ring buffer that stores incoming mouse data has overflowed (buffer 
size is configurable via the registry).
Dump of event data:
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0000: 00 00 08 00 01 00 62 00 ..?.b.
0008: 00 00 00 00 0B 00 05 40 ....?.?@
0010: F2 4E 00 00 00 00 00 00 =N......
0018: 00 00 00 00 00 00 00 00 ........
0020: 00 00 00 00 00 00 00 00 ........
0028: 18 00 00 00 60 09 00 00 ?...‘ ..

*******************************************************************
.
.
.

3.3.6 Analyzing Events

To produce an analysis of an event, enter the following CLI command:

deceventcli /a EventFilename 

Where EventFilename refers to the name of the event file.

Output

.NT.evt
DECeventCLI NT v4.0
Fri Sep 03 08:53:57 1999
-------------------------------------------------------------------
Processing : "tl6.7_vms_630_0082_0044.NT.evt"
Criteria Match : 1 of 1 events

*******************
* Analysis *
*******************

Callout Number: TL630.82.44
FullDescription:

---- Product Information ----
System Type: AlphaServer 8400 Model GS140 67/700
System Name: EveVMStoNT
System Serial Number: BOGUS123

---- Error Environment ----
Record Number(s): 1
Time of Error(s): 03-Dec-1996 22:51:57:00

---- Error Description and FRU Callout ----
Store instruction of less than quadword length caused a Dcache ECC error.
(Refer tp EV6 specification chapter 7 for details.)

Most Probable Cause of Failure
Device Type : TLEP
Description : Turbo Laser Unknown Type
FRU Callout : Unknown
FRU Location: TLSB 0
*******************************************************************
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Frequently Asked Questions

The following is a compilation of Frequently Asked Questions (FAQs) regarding DECevent 
NT.

Q: Can I analyze data collected from an Alpha machine on an Intel machine and expect the 
same results?

A: If you use the Analysis function, yes. If, however, you use the Translation function, then 
this may or may not work. Because Translation uses the installed drivers to decode what type 
of error the event is, reporting is specific to the driver that wrote the error. Keep in mind that 
Alpha drivers have the information; Intel drivers do not.

Q: Will Automatic Analysis run on an Intel platform?

A: Yes, but the drivers on the Intel platform will not supply the needed information to do 
analysis, so you will really only get translation.

Q: Will DECevent NT produce a Translation without doing the bit-to-text piece?

A: No.

Q: What is Bit to Text?

A: Bit to Text, or BTT, converts the value of the fields into readable text.
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A | A | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z  

A

Analysis

Analysis uses inference to determine the cause of an error. When pertinent information is available 
for known errors, DECevent NT infers a service repair action and recommends which Field 
Replaceable Unit to replace in the analysis output. These events display on the screen and can be 
printed or sent via electronic mail.

Analysis Debugging Tab

Access this tab to select flags that will produce debugging output and trace information during an 
analysis. The debug information displays in a separate analysis window.

Analysis Window

This window shows the results of an event analysis.

Application Event Log

An Application Event Log is a crash file that stores correctable and uncorrectable errors until the 
user retrieves them for analysis or translation.

Auto Analysis Tab 

One of the tabs in the Automatic Analysis & Notification Manager window, the Auto Analysis Tab 
allows you to specify which system logs to track and the time period for scanning events. You can 
also perform a test analysis and review the operating status of the Automatic Analysis background 
service.
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Automatic Analysis 

Automatic Analysis translates data from an event log into usable segments of information. All 
entries received in the event log are immediately sent for analysis. The event log is then monitored 
for a specified time period and tracks the number of identical events that occur. When a 
predetermined number of event logs is exceeded, the events are then conveyed to the user and noted 
as a potential problem.

Automatic Notification 

Automatic Notification allows you to establish notification modules that report the error log along 
with suggested repair information, registry information, and the previous repair history. You can set 
up electronic mail notification, system-initiated call logging system (SICL), or a web-based 
self-help system that provides suggestions on how to fix a particular fault detected in the system.

C

Correctable Error 

These errors do not cause the computer system to shut down. When a correctable error occurs, the 
operating system device driver collects the information and writes it directly into the Application 
Event Log.

D

DSNlink 

DSNlink is a service tool that authorized users can use to obtain electronic product support. 
DSNlink’s cryptographic authentication procedures ensure secure communications between
DSNlink system at a customer site and the DSNlink host systems at Compaq Customer Sup
Centers.

E

Edit Menu 

The Edit menu allows you to perform basic editing tasks with your file. You can cut, copy, pas
delete an event or events. Refer to the Status Bar for an explanation of each pull-down optio

Event Window 

The Event Window is the main window that appears in DECevent NT. It lists all of the system
events. Multiple Event Windows can be accessed at one time.
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File Menu 

From the File menu, you can access Windows NT’s System, Security, and Application Event 
and you can open, close, save, or print the active DECevent NT file(s). You can also connec
another computer’s event log, send a log through electronic mail, look at the most recent DEC
NT files, and exit DECevent NT entirely.

H

Help Menu 

The Help pull-down menu gives you access to DECevent NT’s online help files and reveals sp
copyright and version information.

K

Knowledge Rule Sets Tab 

The Knowledge Rule Sets tab allows you to add or exclude Rule Sets from the analysis pro
Some Rule Sets are automatically enrolled when DECevent NT is installed.

M

Menu Bar 

The Menu Bar contains six common Windows NT pull-down menus–File, Edit, View, Window
Options, and Help. These menus allow you to perform the necessary actions that DEcevent
supports.

N

Notification Tab 

The Notification Tab is one of the options you can access in the Automatic Analysis & Notifica
Manager window. From this tab, you can establish the notification method that reports errors, 
the notification status, and access customer profile information.
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Options Menu 

The Options menu lets you set up how you want your Analysis and Translation functions to 
perform. You can define Rule Sets and Debugging Flags, start the Automatic Analysis & 
Notification Analysis Manager, and alter the analysis and notification settings. In addition, you can 
manipulate the various text output settings.

S

Security Event Log 

This log records security events, tracks changes to the security system, and identifies any possible 
breaches to the security settings.

Status Bar 

The Status Bar appears in the lower left-hand corner of the main DECevent NT window and 
indicates what action will occur after the touch of a mouse.

System Event Log 

The System Event Log records events that affect the system’s components.

System-Initiated Call Logging (SICL)

SICL is one type of automatic notification that transfers event information directly to a Custo
Service Center.

T

Toolbar 

The Toolbar contains eight common Windows NT shortcut icons that allow you to create, op
save, cut, copy, paste, and print an event or events. You can also access the online help.

Translation 

During translation, the binary portion of an event log is translated into plain text. Additional 
information is added to the translated events to help determine the error that has occurred. S
Application, and Security events may be translated.

Translation Window 

When you translate an event, the results will appear in a separate Translation Window. Throu
Options menu, you can set the specifications for how this window should appear.
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U

Uncorrectable Error 

An uncorrectable error occurs when a fault within a computer or a piece of associated hardware 
causes the system to detect an inconsistency in its mode of operation. The system writes the event 
into an Application Event Log, and the system then shuts itself off.

V

View Menu 

The View menu lets you specify which components you would like to show in the DECevent NT 
window and allows you to analyze a particular event or events.

W

Window Menu 

The Window pull-down menu allows you to select how you want the overall DECevent NT window 
to appear. You can choose to open a new window, cascade or tile multiple windows, or arrange icons 
to your specification. You can also toggle to another file if more than one file is open.
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